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IAR Embedded Workbench C-SPY 

Abstract 

This document describes the usage of the IAR Embedded Workbench C-SPY 
debugger as target system. Normally, only a C-SPY project file template and the 
debug general file need to be adjusted to the specific configuration of your hardware. 

More adjustments may be needed when using real hardware.  

 

Important note: If you are using an emulator you will most likely have to disable your 
watchdog (see chapter 2.6). 

 

Important note: The latest adaption uses cspybat for normal test runs (see chapter 
2.1.4) and the IAR Embedded Workbench for interactive debugging. The Run to box 
must contain _exit (see chapter 2.1.2). 

 

Important note: For current versions of TESSY you must set the macro file path to 
tessy_cspy.mac as described in chapter 2.1.2. 
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1 IAR C-SPY 

In order to run tests with the IAR Embedded Workbench respectively cspybat an IAR 
project file and a C-SPY macro file is needed. 

A sample project file and the corresponding settings files are located in subdirectory 
sys\targets\iar of the TESSY installation directory. 

The C-SPY macro file which is used to handle the C-SPY debugger will be generated 
from a template file that is specified within the TESSY Environment Editor (TEE) (see 
chapter 2.2). You may add your own macro code or call your own macros by 
changing this template file. Be careful with any changes, since this may cause the 
communication between TESSY and C-SPY to fail. 

Since version 4.2.3 TESSY copies the target binary of your test object into TESSY´s 
test object directory. Thus simulator unit tests can run in parallel. 

The examples in this application note have been tested for version V6.0 of the IAR 
Embedded Workbench running a MSP430 CPU.  

For interactive debugging TESSY starts the IAR Embedded Workbench before each 
test execution. So please close all running instances of IAR Embedded 
Workbench before starting a TESSY test run with breakpoint set. 

2 Project and Setup File Templates 

Please specify the IAR project and setup files to be used within the TESSY 
Environment Editor. You may either adapt the given IAR project files (located in 
\sys\targets\iar of your TESSY installation) or create a new IAR Embedded 

Workbench project file and adjust it as described below.  

  

Please note: It is recommended to copy the default IAR project files from 
\sys\target\iar to the subdirectory \tessy\config of your TESSY project or 

create new ones. Update the TEE attributes Project File and Setup File accordingly 
(see chapter 2.2). 
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2.1 Generating the Target Binary 

If you want to modify an existing project file template or create a new project file from 
scratch, you will have to build a binary file from within TESSY at first. The steps 
below describe how this is done. 

• Create a new TESSY project and prepare your test as described in the TESSY 
User Manual. 

• Select the IAR compiler and IAR Embedded Workbench as TESSY 
environment.  

• Generate the test driver and run the test using the default options. 

• When the IAR Embedded Workbench appears, ignore any error messages 
and close the IDE. Stop the test execution from within TESSY. 

 

After performing these steps, you will find the generated test driver binary within the 
working directory of your TESSY project directory which is found by selecting the 
General tab of the Properties view, open the context menu of the Test Directory 
text field, and click Copy to copy the path. 

 

2.1.1 Creating a new Project File Template 

Open the IAR Embedded Workbench and choose Create New Project from the 
Project menu. Select Empty project within the dialog and click OK. 

 

 

 

Save the project into the TESSY project test object directory (the path you just 
copied) and name it ‘ts_slave’. 
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2.1.2 Adjusting Project File Settings 

Select the new project and choose Add->Add Files… from the context menu. 
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Within the dialog (see below) choose All Files from the file type combo box and 
select the binary file you just created with TESSY of which name begins with 
ts_slave.d… (e.g. ts_slave.d43). Other processors may result in different file 

extensions for the binary file. 

 

 

 

Click ‘Open’.  

 

• Open the context menu of the project and choose Options…. 
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• Select General Options and specify your processor variant (Device). 

      

 

• Select the tab Output. 

• Make sure that there is no subdirectory to the executable. 
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• Select the tab Library Configuration. 

• In the Library combo box select Normal DLIB. 

 

 

Note: If you need to use a different library refer to chapter 2.5. 

• Select the category Debugger. 
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• Checkmark Use macro file and copy the following string into the input field: 
tessy_cspy.mac.  

This file will be created by TESSY before and executed right after startup of 
the C-SPY debugger by the IAR Embedded Workbench. It handles the test 
execution and the communication process between C-SPY and TESSY. 

• It is crucial to fill into the Run to box the symbol _exit. This will start the 
program automatically after the debugger starts. The default value, main, does 
not suffice! 

After you have successfully initialized your project please save the IAR 
workspace and the IAR project. 

• From the File menu choose Save Workspace and select ts_slave.eww as file 
name and click Save. 
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• Click ‘Yes’ to override the existing workspace. 

 

• From the File menu select Save All to save the project. 

 

• Finally, try to download and debug the binary created by TESSY. 
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• If you are using hardware instead of a simulator perform all necessary steps. 

• Close the IAR Embedded Workbench. 

 

2.1.3 Copying the Project Files 

After you have finished the setup of the IAR project you have to copy the created files 
to another location (e.g. into \tessy\config of your TESSY project directory). 

The following files and directory have to be copied:  

 

After you have copied the files you can rename them but make sure that all files 
including the files of the settings directory have the same base name. 

Now update your TEE attributes Project File and Setup File appropriately (refer to 
chapter 2.2). 

 

2.1.4 Prepare cspybat files 

For normal test runs (without interactive debugging) TESSY uses cspybat which in 
current versions of the IAR Embedded Workbench needs two special files—
ts_slave.Debug.driver.xcl and ts_slave.Debug.general.xcl which are 

found both in the settings folder of the IAR Embedded Workbench’s project 

directory. 

Please open file ts_slave.Debug.general.xcl and change the paths to the test 

binary and to the macro file as shown below. The file extension of the binary depends 
on your target and may differ from this example. 

 



TESSY Application Notes   

TESSY Application Note #014, 04 May 2023  Page 12 of 20 

Razorcat Development GmbH 

Witzlebenplatz 4   14057 Berlin    Tel. +49 (0) 30 - 536 357 - 0    Fax +49 (0) 30 - 536 357 – 60 

support@razorcat.com 

Make sure the TEE attributes Debug Driver File and Debug General File point to 
the files used for the test run. For older versions of cspybat the commands normally 
found in these files are given on command line for cspybat. Please refer to chapter 
3.4 for further instructions. 

2.2 TESSY Environment Editor (TEE) Settings 

Adjust the following attributes properly: Embedded Workbench Path, Config 
Header File, Library, Linker Files, Compiler Defines, and Compiler Includes. 

 

 

Select the appropriate IAR project and setup files. 
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2.3 Determining the Compiler and Linker Options 

To determine the compiler and linker options used by your original developer project 
(not the one created above) you may copy the build messages within the IAR 
Embedded Workbench from the Build console. In the IAR Embedded Workbench 
select Messages->Build from the View menu. 

 

 

 

Rebuild your original IAR project. Open the context menu from the Build console and 
select All. Now press and hold Control on your keyboard and select the compiler 
and linker command lines. Open the context menu again, click Copy, and paste the 
command lines into an editor of your choice. 

 

 

 

To determine the compiler and linker options used in your TESSY project please 
enable the logging of the Makefile commands (Help->Logging…->Makefile 
commands) and start a test run. The compiler and linker command line are displayed 
in the Console view of TESSY. 

You can now compare the compiler and linker options TESSY is using with those you 
are using in the IAR Embedded Workbench. Additional options can be added in the 
TEE (refer to chapter 2.2). Changes can also be done in the Makefile template (refer 
to the TEE attribute Makefile Template to determine the currently used template).  
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2.4 Adjusting the Executable File Extension 

TESSY uses a default file extension depending on the IAR compiler. If this default 
value does not fit please adjust the TEE attribute ExeFile Extension. To determine 
the file extension for the IAR compiler, take a look at the project tree within the IAR 
Embedded Workbench. 

 

  

 

In the TEE activate the Expert Mode and adjust the attribute ExeFile Extension. 

 

 

 

2.5 Using CLIB instead of DLIB (for deprecated compilers) 

If you have to use CLIB instead of DLIB perform the following steps: 

• Delete the entry of the TEE attribute Config Header File. 

• Select the appropriate library (TEE attribute Library). 
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2.6 Disabling the Watchdog 

When using an emulator instead of the simulator it is necessary to disable the 
watchdog timer in order to run tests with TESSY. How to disable the watchdog 
depends on the microcontroller in use. Please refer to the manuals of the respective 
hardware manufacturer. 

Normally, the watchdog needs to be disabled by writing to a specific microcontroller 
register. This can be done with the TEE attribute Init Definitions. You may have to 
include the register definition header files or declare the register directly at a specific 
address. This depends on the microcontroller in use. 

Please note, the 78K0 requires an option byte to be defined and initialized as 
described below. For example the following code has to be placed into the TEE 
attribute Init Definitions (i.e. for NEC µPD78F0881). 

__root const unsigned char opbyte[5] @ 0x080 ={0x6E,0x00,0x00,0x00,0x02}; 
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3 Troubleshooting 

3.1 Startup of the C-SPY Debugger fails 

If the debugger hardware is not connected or if there are other hardware related 
problems (e.g. wrong device file) you will get error messages as shown below within 
the Debug Log view of C-SPY. 

 

In this case abort the test from within TESSY and follow the instructions above to 
change the hardware settings. Ensure that the debugger within the IAR Embedded 
Workbench starts without errors using the project template files that are used by 
TESSY. 

3.2 Test Execution Stops during Debugging 

If the test execution process is stopped within C-SPY before the test is actually 
finished assure that the watchdog is disabled. 

3.3 The IAR Project Files have the Wrong Version 

The default EWB project files from \sys\targets\iar of your TESSY installation 

have been created with a specific version of the IAR Embedded Workbench. You will 
probably have to create your own project files with your version of the workbench. 

If the following dialog appears 
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your project file is to old. You can convert it by clicking ‘Yes’ or create a new one as 
described above (refer to chapter 2).  

If you click ‘Yes’ you have to copy (and rename it if necessary) the converted project 
and setup files from the TESSY test area to the directory where your project file 
resides (see the TEE attributes Project File and Setup File (refer to chapter 2.2)). 

If the following dialog appears your project file is to new. 

 

Thus you have to create a new one with your currently used version of the EWB (see 
chapter 2). 

3.4 Startup of cspybat fails 

 

Unless you have on older versions of IAR Embedded Workbench check the TEE 
attributes Debug Driver File and Debug General File (see chapter 2.1.4). 

If you are using an IAR Embedded Workbench version which creates no driver 
respectively general file you may edit file ts_slave.Debug.cspy.bat from the 

settings folder of your C-SPY project. In this case you can ignore the TEE 

attributes Debug Driver File and Debug General File. Activate Expert Mode in 
TEE. Copy the last cspybat command line, e.g. 

"E:\IARSystems\EWB7.0_MSP430_610\common\bin\cspybat" 

"E:\IARSystems\EWB7.0_MSP430_610\430\bin\430proc.dll" 

"E:\IARSystems\EWB7.0_MSP430_610\430\bin\430sim.dll" %~1 --plugin 

"E:\IARSystems\EWB7.0_MSP430_610\430\bin\430bat.dll" --macro 

"C:\tessy\testarea\tessy_cspy.mac" --backend -B "--hardware_multiplier" 

"32" "--hwmult_type" "8" "-p" 

"E:\IARSystems\EWB7.0_MSP430_610\430\config\debugger\MSP430F5358.ddf" "--

core=430Xv2" "--data_model=small" "--iv_base" "0xFF80" "--odd_word_check" 

"-d" "sim" "--derivativeSim" "MSP430F5358" 
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Substitute %~1 (some IAR Embbedded Workbench versions use %1 as place holder) 

for ts_slave$(ExeFile Extension) and paste the resulting string into TEE attribute 

Slave Call. So, in our example the resulting Slave Call value would look like the 
following. 

$(MODULEPATH):@:"E:\IARSystems\EWB7.0_MSP430_610\common\bin\cspybat" 

"E:\IARSystems\EWB7.0_MSP430_610\430\bin\430proc.dll" 

"E:\IARSystems\EWB7.0_MSP430_610\430\bin\430sim.dll" ts_slave$(ExeFile 

Extension) --plugin "E:\IARSystems\EWB7.0_MSP430_610\430\bin\430bat.dll" –

macro tessy_cspy.mac --backend -B "--hardware_multiplier" "32" "--

hwmult_type" "8" "-p" 

"E:\IARSystems\EWB7.0_MSP430_610\430\config\debugger\MSP430F5358.ddf" "--

core=430Xv2" "--data_model=small" "--iv_base" "0xFF80" "--odd_word_check" 

"-d" "sim" "--derivativeSim" "MSP430F5358" 

3.5 Interactive debugging fails 

 

Stop the debugger by terminating the unit test from within TESSY. Make sure you set 
the path to the correct macro file path, i.e. tessy_cspy.mac. You must not use 

any other path! 
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3.6 cspybat is missing 

You may either restart your IAR installation file and install cspybat or configure your 
TESSY project to use the IAR Embedded Workbench for the non-interactive unit 
tests as well. This is easily done. Set TEE attribute Slave Call to the value of 
$(Slave Debug Call). Set TEE attribute Enable C-SPY Bat to false. Both 

attributes are visible in TEE’s Expert Mode. 
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3.7 Pragma still open error 

If you encounter a similar error as shown below, you should use the legacy version of 
the IAR IDB Makefile, i.e. iar-idb-legacy.mak. 

***** Compiling Communication Modules ****** 

  #include "tsteval.h" 

                      ^ 

"C:\TESSYS~1.3\168319~1\PROJEC~1\tessy\work\00000401\00000402\

00000403\0000040A\ts_src01.c",1260  Error[Pa074]:  

          "#pragma language = save" at line 1256 still open 

    #pragma language=restore 

                            ^ 

"C:\TESSYS~1.3\168319~1\PROJEC~1\tessy\work\00000401\00000402\

00000403\0000040A\ts_src01.c",1270  Error[Pa075]:  

          no matching save pragma 

 


